Annonce

[12 janvier 2021] - En prévision d'un abandon futur du nom de domaine phpcodeur.net, le forum a migré vers le nom de domaine forum.webnaute.net
[25 janvier 2021] - Publication de Wanewsletter 3.1.0

#1 Re : Discussions » PITIÉ AIDEEEEEZZZZZZZ MOIIIIIII !!!!!!!! » 2009-05-29 15:50:52

Merci, là aussi!

Je vais aller jeter un oeil plus scrutateur...


:sage:

#2 Re : Discussions » envoyer au format HTML » 2009-05-29 15:30:48

smile Merci de tes conseils,
En fait tout semble passer quand on intègre ABSOLUMENT TOUT le code de la page dans le champ html, y compris les styles CSS.
Mieux vaut, semble-t-il éviter texte et html... j'ai remarqué qu'autrement il arrive que seule la version pur texte est reçue...!?
Pour que IE s'y retrouve, il faut quasi en revenir à l'antiquité: table-tr-td! Autrement la newsletter devient un site à elle toute seule avec son fastidieux alignement de commentaires conditionnels!
Mais, cela passe...
Faut que j'essaye de recevoir la version html en réglant me mail sur texte... pour observer ce que cela donne.

A+

#3 Re : Discussions » PITIÉ AIDEEEEEZZZZZZZ MOIIIIIII !!!!!!!! » 2009-05-26 12:19:34

yikes  yikes RECTIFICATIF:
CELA NE FONCTIONNE QUE BIZARREMENT!!

En fait un envoi avec texte dans le champ TEXTE, COMBINÉ avec un envoi dans le champ HTML, ENVOIE 2 lettres!!! Une seulement en texte et l'autre seulement en html!!!
Il faut donc que j'aille RE-cocher dans les options...  :oops:

Par ailleurs, ayant jeté (comme demandé après installation) le répertoir des réglages, je suppose qu'il faut agir directement dans la BD pour effectuer certains changements, tel que: ne pas demander confirmation d'inscription?

#4 Re : Discussions » Test de Wanewsletter depuis le 25 mai 2009 » 2009-05-26 11:57:35

roll  :oops:
1) J'ai (enfin) vu qu'il y a une option texte ET html. J'ai collé une de mes anciennes news dans le champ html et c'était bon!
2) Ben... y'a un bouton "prévisualiser!  Ggh!

Pour le reste ( 3 et 4), c'est encore un mystère...

EDIT:
De plus, je ne comprends pas non-plus très bien ce qui se passe avec ce lien à form.php qui figure en message de confirmation.

#5 Re : Discussions » PITIÉ AIDEEEEEZZZZZZZ MOIIIIIII !!!!!!!! » 2009-05-26 11:30:41

:joke: Et tac! Cette fois-ci cela fonctionne!
Ce n'est pas évident d'entrer dans une logique en 24 heures (moins dodo et miam-miam) mais voici où j'en suis (si cela peut éventuellement intéresser ou aider quelqu'un):

1) J'ai eu le temps de constater qu'il y a un bouton "Prévisualiser" sous LES fenêtres
2) Il a d'abord fallu que je découvre l'option texte et html, pour comprendre que je ne pouvais EN AUCUN CAS envoyer ma "vraie" newsletter par le champ de texte "texte"... :idea:
3) J'ai repris une de mes anciennes newsletters et en ai collé le code source, complet, dans la fenêtre html.
4) On ne peut envoyer une newsletter html SANS AVOIR MIS un texte (ne serait-ce qu'un point) dans la zone "texte", AVEC le LINK de désinscription
5) Le LINK de désinscription DOIt figurer dans les DEUX fenêtres
6) J'ai dû manuellement remplacer 0 par 1 dans la Base de donnée, car je rencontre encore des problèmes avec une page liée à la désinscription.
7) De ce fait, mon formulaire d'envoi me chicane encore en n'affichant que la liste est vide... mais refuse une inscription, sous prétexte qu'elle existe déjà... A voir, donc

Merci à miasma et à l'attention à qui que ce soit ayant pris du temps à me lire.  wink

Je continue mes tests.

A+

#6 Re : Discussions » PITIÉ AIDEEEEEZZZZZZZ MOIIIIIII !!!!!!!! » 2009-05-26 09:18:14

roll Heuh... Ben ça fonctionne pas... Il n'y a que la fenêtre "texte" qui envoie du texte... La fenêtre "html" n'envoie rien du tout!...
Pourtant j'ai choisi l'option texte et html...
Comprends pas... Il faut aussi cliquer et re-cliquer quelque part pour confirmer le clic du clic? :mhh:

#7 Re : Discussions » PITIÉ AIDEEEEEZZZZZZZ MOIIIIIII !!!!!!!! » 2009-05-26 08:48:44

Merci miasma,

Voilà déjà une excellente aide!
Qu'en est-il des conseils de ne pas remettre <head> ni <body> pour ses newsletter (dégradation automatique de certains moteurs) et de ne mettre que l'encapsulage <div>, à la place?

J'aurai sûrement encore plein de questions au cours de la journée (je dois rapidement déterminer si Wanewsletter correspond aux besoins)... J'espère que tu sera assis devant ton ordi...  ;P

Cordialement

Almux

#8 Re : Discussions » Test de Wanewsletter depuis le 25 mai 2009 » 2009-05-26 08:10:45

Bonjour à toutes et à tous,

Depuis hier j'ai installé Wanewsletter sur mon serveur distant pour le tester.
Dans l'ensemble, le travail accompli est techniquement superbe... Mais, je travail dans le domaine du visuel et la newsletter doit impérativement avoir le même graphisme (ou, pour le moins, respecter la charte graphique) que le site auquel elle se réfère.
J'ai donc toute une série de questions urgentes et dont les réponses seront déterminantes en vue d'utiliser ou non Wanewsletter ces prochains temps:
1) Comment intégrer le code complet d'une page dans le formulaire d'envoi (images comprises) pour obtenir une belle lettre html?
  (Je suis déjà allé visiter les 3 sites conseillés dans les "Stickers" de ce forum, mais c'est pas gagné...)
2) Y a-t-il un moyen plus rapide de visualisation du résultat, que celui de se créer une liste "testeur" et de s'y envoyer la newsletter?
3) Comment faire s'inscrire les messages d'alerte (et autres "votre inscription est...") dans la même DIV que le formulaire d'inscription-désinscription?
4) J'ai vu qu'il y a des "templates" dans un dossier. Comment les visualiser?

Vos réponses me seraient extrêmement utiles et je vous en remercie d'avance.

Almux

EDIT
Je vais ressayer Wanewsletter avec une copie du formulaire SANS UI CSS pour vérifier si les problèmes de non-confirmation des inscriptions y sont liés.

#9 Re : Discussions » Wanewsletter 2.3.2 OU EST LE formulaire de confirmation ? » 2009-05-26 07:46:17

Je cherche aussi, depuis hier.
J'ai créé une page de redirection form.php au niveau demandé par le script... Cela me même sur une page que j'ai créé avec une CSS perso. La désinscription semble fonctionner (j'hésite à enlever le bouton "inscription", car il semble aussi effacer l'adresse inscrite!).
Par contre, ma page CSS semble cacher toutes les informations utiles. Les messages d'alerte et autres sont derrière le beandeau.
Je dois absolument découvrir aujourd'hui si Wanesletter va me permettre de créer les newsletters selon mes besoins visuels ou si je dois abandonner...

En fait, le plus simple (mais un peu moins poli) c'est de ne pas demander de confirmations et de mettre un ENOOOORME délais de réponse à l'inscription... Ensuite, il faut garder une copie texte de sa liste d'adresses pour, à la rigueur, créer une nouvelle liste complète pour les prochains envois...  neutral

#10 Re : Discussions » envoyer au format HTML » 2009-05-26 07:38:51

:fou2: Je suis à peine arrivé... je cherche encore comment fonctionne la mise en page.
Dès que j'aurai eu tous les renseignements, je te dis... wink

EDIT: voir Discussions/PITIE...

#11 Re : Discussions » PITIÉ AIDEEEEEZZZZZZZ MOIIIIIII !!!!!!!! » 2009-05-26 07:36:17

Hello,
J'ai aussi eu quelques bulles... mais ce n'est, en fait qu'un problème de logique.
J'ai l'habitude du travail linéaire et simple (OSX), mais pour l'upload, il faut sélectionner l'image d'un dossier par un clic sur le bouton supérieur. Ensuite cliquer sur le bouton inférieur... cela met l'image en attente (au bas de l'interface) et prête à l'expédition. MAIS elle disparaît alors du formulaire (zone texte du choix d'image). Si on essaye d'envoyer la newsletter sans que l'image n'apparaisse dans la liste en bas de page, l'image ne peut exister dans la lettre.
C'est un peu du clicage multiple, mais on peut s'y faire.

Par contre, comment la placer selon envie dans la newsletter... là, je l'ignore encore... Je n'ai découvert Wanewsletter que hier...!

Pied de page des forums

Propulsé par FluxBB